// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\.((((c|C)(c|pp|xx|\+\+)?$)|((h|H)h?(pp|xx|\+\+)?$))|(ino|pde|proto|cu))$").unwrap();
let string = "./test/known_fail/addition.c
./test/known_fail/addition.C
./test/known_fail/addition.cpp
./test/known_fail/addition.cc
./test/known_fail/addition.c++
./test/known_fail/addition.cxx
./test/known_fail/addition.ino
./test/known_fail/addition.pde
test/known_fail/addition.proto
test/known_pass/addition.proto
./test/known_fail/test.h
./test/known_fail/test.H
./test/known_fail/test.hpp
./test/known_fail/test.hh
./test/known_fail/test.h++
./test/known_fail/test.hxx
./.git/objects/13
./.clang-format
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}