#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([ก-ฮ]{1,3}\d{1,4})|\d{1}([ก-ฮ]{1,3}\d{1,4})"
Local $sString = "กข1234" & @CRLF & _
"กข123" & @CRLF & _
"กข12" & @CRLF & _
"กข1" & @CRLF & _
"กขค1234" & @CRLF & _
"กขค123" & @CRLF & _
"กขค12" & @CRLF & _
"กขค1" & @CRLF & _
"1กข1234" & @CRLF & _
"1กข123" & @CRLF & _
"1กข12" & @CRLF & _
"1กข1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")