package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#\w+$`)
var str = `valid inputs:
#hashtag_abc
#simpleHashtag
Invalid inputs:
#hashtag#
#hashtag@hashtag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}