#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])"
Local $sString = "R" & @CRLF & _
"C" & @CRLF & _
"RC" & @CRLF & _
"RC[1]" & @CRLF & _
"RC[-1]" & @CRLF & _
"R[1]C" & @CRLF & _
"R[-1]C" & @CRLF & _
"R[1]C[1]" & @CRLF & _
"R[-1]C[1]" & @CRLF & _
"R[1]C[-1]" & @CRLF & _
"R[-1]C[-1]" & @CRLF & _
"R[foo]" & @CRLF & _
"C[foo]" & @CRLF & _
"R[foo]C" & @CRLF & _
"RC[foo]" & @CRLF & _
"R[foo]C[foo]" & @CRLF & _
"RC[0]" & @CRLF & _
"RC[0]" & @CRLF & _
"R[0]C" & @CRLF & _
"R[0]C" & @CRLF & _
"R[0]C[0]" & @CRLF & _
"R[0]C[0]" & @CRLF & _
"R[0]C[0]" & @CRLF & _
"R[0]C[0]" & @CRLF & _
"RC[99]" & @CRLF & _
"RC[-99]" & @CRLF & _
"R[99]C" & @CRLF & _
"R[-99]C" & @CRLF & _
"R[99]C[99]" & @CRLF & _
"R[-99]C[-99]" & @CRLF & _
"R[99]C[-99]" & @CRLF & _
"R[-99]C[99]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")