package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])`)
var str = `R
C
RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[foo]
C[foo]
R[foo]C
RC[foo]
R[foo]C[foo]
RC[0]
RC[0]
R[0]C
R[0]C
R[0]C[0]
R[0]C[0]
R[0]C[0]
R[0]C[0]
RC[99]
RC[-99]
R[99]C
R[-99]C
R[99]C[99]
R[-99]C[-99]
R[99]C[-99]
R[-99]C[99]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}