const regex = /R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('R(\\[-?\\d+\\])C(\\[-?\\d+\\])|R(\\[-?\\d+\\])C|RC(\\[-?\\d+\\])', 'g')
const str = `R
C
RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[foo]
C[foo]
R[foo]C
RC[foo]
R[foo]C[foo]
RC[0]
RC[0]
R[0]C
R[0]C
R[0]C[0]
R[0]C[0]
R[0]C[0]
R[0]C[0]
RC[99]
RC[-99]
R[99]C
R[-99]C
R[99]C[99]
R[-99]C[-99]
R[99]C[-99]
R[-99]C[99]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}