use strict;
my $str = 'R
C
RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[foo]
C[foo]
R[foo]C
RC[foo]
R[foo]C[foo]
RC[0]
RC[0]
R[0]C
R[0]C
R[0]C[0]
R[0]C[0]
R[0]C[0]
R[0]C[0]
RC[99]
RC[-99]
R[99]C
R[-99]C
R[99]C[99]
R[-99]C[-99]
R[99]C[-99]
R[-99]C[99]
';
my $regex = qr/R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}