$re = '/R(\[-?\d+\])C(\[-?\d+\])|R(\[-?\d+\])C|RC(\[-?\d+\])/';
$str = 'R
C
RC
RC[1]
RC[-1]
R[1]C
R[-1]C
R[1]C[1]
R[-1]C[1]
R[1]C[-1]
R[-1]C[-1]
R[foo]
C[foo]
R[foo]C
RC[foo]
R[foo]C[foo]
RC[0]
RC[0]
R[0]C
R[0]C
R[0]C[0]
R[0]C[0]
R[0]C[0]
R[0]C[0]
RC[99]
RC[-99]
R[99]C
R[-99]C
R[99]C[99]
R[-99]C[-99]
R[99]C[-99]
R[-99]C[99]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);