import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?\\:\\/\\/|[a-zA-Z0-9]?)([a-zA-Z0-9\\-]+\\.host\\.[a-zA-Z0-9]+$|host\\.[a-zA-Z0-9]+$)";
final String string = "#### should MATCH all of these:\n"
+ "http://www.host.com\n"
+ "https://www.host.com\n"
+ "https://www.host.com\n"
+ "http://host.com\n"
+ "http://www.host.tv\n"
+ "https://www.host.live\n"
+ "host.com\n"
+ "www.host.com\n"
+ "http://sub-services.host.com\n"
+ "sub-services.host.com\n"
+ "g.host.com\n"
+ "gg.host.com\n"
+ "gggg.host.com\n"
+ "something-services.host.com\n\n"
+ "#### should NOT MATCH all of these:\n"
+ "http://www.something.com\n"
+ "http://www.host-something.com\n"
+ "http://www.host.something-com\n\n"
+ "http://www.hosts.com\n"
+ "https://www.host\n"
+ "https://www.host.live.com\n"
+ "http://.host.com\n"
+ "http://www.host.tv.com\n"
+ "something.com\n"
+ ".host.com\n"
+ "www.com\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}