package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\bi am\b(.*) (sad|unhappy|depressed|sick)(.*)`)
var str = `i am dunhappy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}