$re = '/(.*)\bi am\b(.*) (sad|unhappy|depressed|sick)(.*)/m';
$str = 'i am dunhappy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);