#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ +\w+([A-Z][a-z]+) += +(?:(?!\1)\w)+$"
Local $sString = "" & @CRLF & _
" aaaBbb = CccBbb" & @CRLF & _
" aaaDddd = CccDddd" & @CRLF & _
" aaaEeee = CccFfff" & @CRLF & _
"" & @CRLF & _
" aaaDddd = CccDdddd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 matches found..." & @CRLF & _
"But I want to match the 3rd line without matching the first 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")