re = /^(?(?=#).*\n(.)|(?(?=.#).*\n.(.)|(?(?=..#).*\n..(.)|(?(?=...#).*\n...(.)|(?(?=^....#).*\n....(.)|(?(?=^.{5}#).*\n.{5}(.)|(?(?=^.{6}#).*\n.{6}(.)|#))))))).*$/m
str = '#AB
xyz
A#B
xyz
X#ZEAKBLA
123456789
XIZEAK#LA
123456789
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end