const regex = /^(HTTP:\/\/)?\K([^[:space:]]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(HTTP:\\\/\\\/)?\\K([^[:space:]]+)', 'gm')
const str = `site.com - org name - title
site.net - other name - another title
HTTP://target.ca - ca site - ca title`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}