$re = '/^(HTTP:\/\/)?\K([^[:space:]]+)/m';
$str = 'site.com - org name - title
site.net - other name - another title
HTTP://target.ca - ca site - ca title';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);