import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SIC:\\s(\\d{2,})\\s";
final String string = "IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}