re = /SIC:\s(\d{2,})\s/
str = 'IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end