import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\sid=\\\"olpProduct[\\s\\S]*?<div[\\s\\S]*?<div[\\s\\S]*?<a\\shref=\\\"[\\s\\S]*?\\/\\/www.amazon.com\\/[\\s\\S]*?\\/[\\s\\S]*?\\/(.*?)\\/ref=olp";
final String string = "<div id=\"olpProduct\" class=\"a-section a-spacing-none\">\n\n"
+ " <div class=\"a-section a-spacing-mini\">\n\n"
+ " <div class=\"a-section a-spacing-mini\">\n"
+ " ‹ <a href=\"https://www.amazon.com/Keds-Womens-Chillax-Laceless-Sneaker/dp/B00MC3R3M6/ref=olp_product_details?_encoding=UTF8&me=\" id=\"olpDetailPageLink\">Return to product information</a>\n\n\n"
+ " <i class=\"a-icon a-icon-text-separator\" role=\"img\"></i>\n"
+ " Every purchase on Amazon.com is protected by an <a href=\"/gp/help/customer/display.html/ref=olp_wa_1?ie=UTF8&nodeId=537868&pop-up=1\" id=\"olpAZGuarantee\" target=\"AmazonHelp\" onclick=\"return amz_js_PopWin('/gp/help/customer/display.html/ref=olp_wa_1?ie=UTF8&nodeId=537868&pop-up=1','AmazonHelp','width=400,height=400,resizable=1,scrollbars=1,toolbar=1,status=1');\">A-to-z guarantee</a>.\n\n"
+ " <i class=\"a-icon a-icon-text-separator\" role=\"img\"></i>\n"
+ " Feedback on this page? \n"
+ " <a class=\"a-link-normal olpFeedbackLink\" href=\"/forms/33ec5bb5-b0aa-4730-9bba-9b346c8d2499\">\n"
+ " Tell us what you think\n"
+ " </a>\n"
+ " </div>\n\n"
+ " <div class=\"a-fixed-left-grid a-spacing-base\"><div class=\"a-fixed-left-grid-inner\" style=\"padding-left:170px\">\n"
+ " <div id=\"olpProductImage\" class=\"a-text-center a-fixed-left-grid-col a-col-left\" style=\"width:170px;margin-left:-170px;float:left;\">\n"
+ " <a class=\"a-link-normal\" href=\"https://www.amazon.com/Keds-Womens-Chillax-Laceless-Sneaker/dp/B00MC3R3M6/ref=olp_product_details?_encoding=UTF8&me=\">\n"
+ " <img alt=\"Return to product information\" src=\"https://images-na.ssl-images-amazon.com/images/I/41p2f8xA8TL._SS160_.jpg\">\n"
+ " </a>\n"
+ " </div>\n"
+ " <div id=\"olpProductDetails\" class=\"a-fixed-left-grid-col a-col-right\" style=\"padding-left:0%;float:left;\">\n\n"
+ " <h1 class=\"a-size-large a-spacing-none\" role=\"main\"> <div class=\"a-section a-spacing-none olpSubHeadingSection\"> <span class=\"a-size-base a-color-secondary\"> </span> </div> Keds Women's Chillax Washed Laceless Slip-On Sneaker, Taupe, 8 M US\n"
+ " </h1>\n"
+ " <div id=\"olpProductByline\" class=\"a-section a-spacing-mini\">\n"
+ " \n\n\n\n\n\n"
+ "by Keds\n\n"
+ " </div>\n\n"
+ " <div class=\"a-section a-spacing-small\">\n"
+ " \n\n\n\n\n"
+ "<span class=\"offerListingPageB00MC3R3M6\">\n"
+ " <span class=\"a-declarative\" data-action=\"a-popover\" data-a-popover=\"{"closeButton":"false","max-width":"700","position":"triggerBottom","url":"/review/widgets/average-customer-review/popover/ref=acr_offerlistingpage_popover?ie=UTF8&asin=B00MC3R3M6&contextId=offerListingPage&ref=acr_offerlistingpage_popover"}\">\n"
+ " <a href=\"javascript:void(0)\" class=\"a-popover-trigger a-declarative\">\n"
+ " </a><a class=\"a-link-normal a-text-normal\" href=\"https://www.amazon.com/product-reviews/B00MC3R3M6/ref=acr_offerlistingpage_text?ie=UTF8&showViewpoints=1\">\n"
+ " <i class=\"a-icon a-icon-star a-star-4-5\"><span class=\"a-icon-alt\">4.3 out of 5 stars</span></i>\n"
+ " </a>\n"
+ " <i class=\"a-icon a-icon-popover\"></i>\n"
+ " </span>\n"
+ " <span class=\"a-letter-space\"></span>\n"
+ " <span class=\"a-size-small\">\n"
+ " <a class=\"a-link-normal\" href=\"https://www.amazon.com/product-reviews/B00MC3R3M6/ref=acr_offerlistingpage_text?ie=UTF8&showViewpoints=1\">\n"
+ " 1,015 customer reviews\n"
+ " </a>\n"
+ " </span>\n"
+ "</span>\n\n\n\n\n\n\n\n\n\n\n\n\n"
+ " <i class=\"a-icon a-icon-text-separator\" role=\"img\"></i>\n"
+ " \n\n"
+ "<style type=\"text/css\">\n"
+ " #auiswfText:hover, .emailImg:hover, .tafSocial:hover{\n"
+ " text-decoration : none !important;\n"
+ " }\n\n"
+ " #tellafriendAUI .emailtext, #tellafriendAUI .emailImg, #tellafriendAUI .tafSocial {\n"
+ " padding : 0px !important;\n"
+ " margin : 0px !important;\n"
+ " text-decoration : none !important;\n"
+ " }\n"
+ "</style>\n\n"
+ "<span id=\"tellafriendAUI\">\n"
+ " \n"
+ "<span class=\"a-declarative\" data-action=\"a-modal\" data-a-modal=\"{"width":450,"popoverLabel":"Share this via Email","name":"taf-aui","url":"/gp/taf/share.html/ref=cm_sw_p_view_ol_4CVhCbJV9Y2JE?ie=UTF8&ASIN=B00MC3R3M6&action=share&contentID=B00MC3R3M6&contentName=offer%20listing%20page&contentType=offer_page&contentURI=%2Fgp%2Foffer-listing%2FB00MC3R3M6&emailTemplate=%2Fgp%2Fpdp%2Ftaf%2Femail%2Fshare-offer-listing-page&placementID=ol_4CVhCbJV9Y2JE&ref=cm_sw_p_view_ol_4CVhCbJV9Y2JE&showSocialSites=1&site=email&tafAUI=1&titleText=Amazon.com%3A%20Buying%20Choices%3A%20Keds%20Women%27s%20Chillax%20Washed%20Laceless%20Slip-On%20Sneaker%2C%20Taupe%2C%208%20M%20US&view=popup","ajaxFailMsg":"Sorry, content is not available. ","header":"Share this via Email","cache":"false"}\" id=\"swfDeclarative\">\n"
+ " <a id=\"auiswfText\" class=\"a-link-normal emailtext\" title=\"Share via e-mail\" href=\"/gp/taf/share.html/ref=cm_sw_l_view_ol_4CVhCbJV9Y2JE?ie=UTF8&ASIN=B00MC3R3M6&action=share&contentID=B00MC3R3M6&contentName=offer%20listing%20page&contentType=offer_page&contentURI=%2Fgp%2Foffer-listing%2FB00MC3R3M6&emailTemplate=%2Fgp%2Fpdp%2Ftaf%2Femail%2Fshare-offer-listing-page&placementID=ol_4CVhCbJV9Y2JE&ref=cm_sw_l_view_ol_4CVhCbJV9Y2JE&showSocialSites=1&site=email&tafAUI=1&titleText=Amazon.com%3A%20Buying%20Choices%3A%20Keds%20Women%27s%20Chillax%20Washed%20Laceless%20Slip-On%20Sneaker%2C%20Taupe%2C%208%20M%20US&view=standalone\">\n"
+ " <span class=\"shareTextAUI\">Share</span><span class=\"a-letter-space\"></span>\n"
+ " </a>\n"
+ " <a id=\"auiSwfEmail\" class=\"a-link-normal emailImg\" title=\"Share via e-mail\" href=\"#\">\n"
+ " <i class=\"a-icon a-icon-share-email\" role=\"img\"></i><span class=\"a-letter-space\"></span>\n"
+ " </a>\n"
+ "</span>\n\n\n\n"
+ " <a id=\"auiSwfFb\" class=\"a-link-normal tafSocial\" title=\"Share on Facebook\" href=\"/gp/taf/share.html/ref=fa?ie=UTF8&=&ASIN=B00MC3R3M6&action=share&contentID=B00MC3R3M6&contentName=offer%20listing%20page&contentType=offer_page&contentURI=%2Fgp%2Foffer-listing%2FB00MC3R3M6&imageURL=&placementID=ol&reftagSuffix=&site=facebook&titleText=Amazon.com%3A%20Buying%20Choices%3A%20Keds%20Women%27s%20Chillax%20Washed%20Laceless%20Slip-On%20Sneaker%2C%20Taupe%2C%208%20M%20US\">\n"
+ " <span class=\"windowParams\" data-network=\"facebook\" data-height=\"400\" data-width=\"700\"></span>\n"
+ " <i class=\"a-icon a-icon-share-facebook\" role=\"img\"></i><span class=\"a-letter-space\"></span>\n"
+ " </a>\n\n\n"
+ " <a id=\"auiSwfTw\" class=\"a-link-normal tafSocial\" title=\"Share on Twitter\" href=\"/gp/taf/share.html/ref=tw?ie=UTF8&=&ASIN=B00MC3R3M6&action=share&contentID=B00MC3R3M6&contentName=offer%20listing%20page&contentType=offer_page&contentURI=%2Fgp%2Foffer-listing%2FB00MC3R3M6&imageURL=&placementID=ol&reftagSuffix=&site=twitter&titleText=Amazon.com%3A%20Buying%20Choices%3A%20Keds%20Women%27s%20Chillax%20Washed%20Laceless%20Slip-On%20Sneaker%2C%20Taupe%2C%208%20M%20US\">\n"
+ " <span class=\"windowParams\" data-network=\"twitter\" data-height=\"400\" data-width=\"700\"></span>\n"
+ " <i class=\"a-icon a-icon-share-twitter\" role=\"img\"></i><span class=\"a-letter-space\"></span>\n"
+ " </a>\n\n"
+ "</span>\n\n"
+ "<script language=\"JavaScript\" type=\"text/JavaScript\">\n"
+ " P.when('A','jQuery').execute(function(A,$) {\n"
+ " $('.tafSocial').unbind('click').click(function() {\n"
+ " var windowParams = $(this).children('.windowParams');\n"
+ " var height = windowParams.data(\"height\");\n"
+ " var width = windowParams.data(\"width\");\n"
+ " window.open(this.href, \"_blank\", \"location=yes,width=\" + width +\",height=\" + height);\n"
+ " return false;\n"
+ " });\n"
+ " A.on.load(function () {\n"
+ " var hashValue = window.location.hash;\n"
+ " var hashIndex;\n"
+ " var swfHashValue = \"_swftext_Swf\";\n"
+ " hashIndex = hashValue.indexOf(swfHashValue);\n"
+ " if (hashValue != \"\" && hashIndex > -1 && typeof(window.swfPopUpShown) === 'undefined') {\n"
+ " $(\"#auiswfText\").click();\n"
+ " window.swfPopUpShown = 1;\n"
+ " }\n"
+ " });\n"
+ " });\n"
+ "</script>\n\n\n\n\n\n\n\n"
+ " \n\n\n\n"
+ " \n"
+ " \n\n"
+ " </div>\n\n\n"
+ " <div id=\"variationsTwister\" class=\"a-section a-spacing-mini\">\n"
+ " \n\n"
+ " \n\n\n\n\n\n\n\n\n"
+ " \n"
+ " \n\n"
+ " <div class=\"a-section a-spacing-micro\">\n"
+ " <span class=\"a-size-base\">Size:</span>\n"
+ " <span class=\"a-size-base a-text-bold\"></span>\n"
+ " </div>\n"
+ " <span class=\"a-dropdown-container\"><select name=\"\" autocomplete=\"off\" data-a-native-class=\"olpTwisterDropdown\" tabindex=\"-1\" class=\"a-native-dropdown a-spacing-small olpTwisterDropdown\">\n"
+ " <option value=\"/gp/offer-listing/B00NNA39IE/ref=olp_twister_all?ie=UTF8&mv_color_name=3&mv_size_name=all\">\n"
+ " Lowest offer for each\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3QSKO/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=0\">\n"
+ " 5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3QU1G/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=1\">\n"
+ " 5.5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3QX72/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=2\">\n"
+ " 6 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3QYQC/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=3\">\n"
+ " 6.5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3R0PQ/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=4\">\n"
+ " 7 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3R23Q/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=5\">\n"
+ " 7.5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3R3M6/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=6\" selected=\"\">\n"
+ " 8 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3R6LO/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=7\">\n"
+ " 8.5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3R9IY/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=8\">\n"
+ " 9 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3RBE6/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=9\">\n"
+ " 9.5 M US\n"
+ " </option>\n"
+ " <option value=\"/gp/offer-listing/B00MC3RCPY/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=10\">\n"
+ " 10 M US\n"
+ " </option>\n"
+ " </select><span tabindex=\"-1\" id=\"olpTwisterDropdownAUI\" class=\"a-button a-button-dropdown a-button-small a-spacing-small\" style=\"min-width: 0.583333%;\"><span class=\"a-button-inner\"><span class=\"a-button-text a-declarative\" data-action=\"a-dropdown-button\" role=\"button\" tabindex=\"0\" aria-hidden=\"true\"><span class=\"a-dropdown-prompt\">\n"
+ " 8 M US\n"
+ " </span></span><i class=\"a-icon a-icon-dropdown\"></i></span></span></span>\n"
+ " <div class=\"a-section a-spacing-micro\">\n"
+ " <span class=\"a-size-base\">Color:</span>\n"
+ " <span class=\"a-size-base a-text-bold\">Taupe</span>\n"
+ " </div>\n"
+ " <ul class=\"a-unordered-list a-nostyle a-button-list a-declarative a-button-toggle-group a-horizontal a-spacing-small\" role=\"radiogroup\" data-action=\"a-button-group\">\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-0\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B0002MB0DM/ref=olp_twister_child?ie=UTF8&mv_color_name=0&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-0-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41jl1EwZjHL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-1\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B005BFV1DO/ref=olp_twister_child?ie=UTF8&mv_color_name=1&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-1-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41XqEgaqwtL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-2\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B00MC3SFXW/ref=olp_twister_child?ie=UTF8&mv_color_name=2&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-2-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41cNhnckTFL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-selected a-button-thumbnail a-button-toggle\" id=\"a-autoid-3\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B00MC3R3M6/ref=olp_twister_child?ie=UTF8&mv_color_name=3&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-3-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41p2f8xA8TL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-4\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B011SBR9PS/ref=olp_twister_child?ie=UTF8&mv_color_name=4&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-4-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/311Xw94d26L._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-5\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B07FYS34S4/ref=olp_twister_child?ie=UTF8&mv_color_name=5&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-5-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41r4qvtmEkL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-6\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B00MC3TVSK/ref=olp_twister_child?ie=UTF8&mv_color_name=6&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-6-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/31YEDbIcNwL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-7\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B016W1Z1RC/ref=olp_twister_child?ie=UTF8&mv_color_name=7&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-7-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41plM8TSFBL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-thumbnail a-button-toggle\" id=\"a-autoid-8\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B0007L7WPS/ref=olp_twister_child?ie=UTF8&mv_color_name=8&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-8-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41NGM8gp7hL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-disabled a-button-thumbnail a-button-toggle\" id=\"a-autoid-9\"><span class=\"a-button-inner\"><input disabled=\"disabled\" class=\"a-button-input\" type=\"submit\" aria-labelledby=\"a-autoid-9-announce\"><span class=\"a-button-text\" aria-hidden=\"true\" id=\"a-autoid-9-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41WBKxWvoLL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </span></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-disabled a-button-thumbnail a-button-toggle\" id=\"a-autoid-10\"><span class=\"a-button-inner\"><input disabled=\"disabled\" class=\"a-button-input\" type=\"submit\" aria-labelledby=\"a-autoid-10-announce\"><span class=\"a-button-text\" aria-hidden=\"true\" id=\"a-autoid-10-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41ap6ahxMRL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </span></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-disabled a-button-thumbnail a-button-toggle\" id=\"a-autoid-11\"><span class=\"a-button-inner\"><input disabled=\"disabled\" class=\"a-button-input\" type=\"submit\" aria-labelledby=\"a-autoid-11-announce\"><span class=\"a-button-text\" aria-hidden=\"true\" id=\"a-autoid-11-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/41QD5K54hPL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </span></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-disabled a-button-thumbnail a-button-toggle\" id=\"a-autoid-12\"><span class=\"a-button-inner\"><input disabled=\"disabled\" class=\"a-button-input\" type=\"submit\" aria-labelledby=\"a-autoid-12-announce\"><span class=\"a-button-text\" aria-hidden=\"true\" id=\"a-autoid-12-announce\">\n"
+ " <img alt=\"\" src=\"https://images-na.ssl-images-amazon.com/images/I/31qtQ78OWiL._SX35_SY35_CR,0,0,35,35_.jpg\" height=\"35\" width=\"35\">\n"
+ " </span></span></span>\n"
+ " </span></li>\n"
+ " <li class=\"a-spacing-mini\"><span class=\"a-list-item\">\n"
+ " <span class=\"a-button a-button-normal a-button-toggle\" id=\"a-autoid-13\"><span class=\"a-button-inner\"><a href=\"/gp/offer-listing/B00NNA39IE/ref=olp_twister_all?ie=UTF8&mv_color_name=all&mv_size_name=6\" class=\"a-button-text\" role=\"button\" id=\"a-autoid-13-announce\">\n"
+ " Lowest offer for each\n"
+ " </a></span></span>\n"
+ " </span></li>\n"
+ " </ul>\n\n"
+ " </div>\n\n"
+ " <div class=\"twisterDivider\"></div>\n\n\n"
+ " </div>\n"
+ " </div></div>\n"
+ " </div>\n\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}