package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w{3,}(?:-(?:\w{3,}))*)-(\w{2})-game-play\b`)
var str = `cricket-ck-game-play
hand-ball-hb-game-play
volley-ball-vb-game-play
soccer-sc-game-play
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}