const regex = /^(?:\d+(?:\.\d+)?)?(?:\|\d+(?:\.\d+)?){0,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+(?:\\.\\d+)?)?(?:\\|\\d+(?:\\.\\d+)?){0,4}$', 'gm')
const str = `5.01|76543|23343|4.32323|3
5.01
5.01|76543
5.01|76543|23343
5.01|76543|23343|4.32323
5.01,543,2343
1|2|3|4|5|6
5.01|76543|23343|4.32323|3|5.4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}