$re = '/\((?=[10]{8})(?=.*1.*).{8}\)/m';
$str = '(11111110)
(11111101)
(11111100)
(11111011)
(11111010)
(11111001)
(11111000)
(11110111)
(11110110)
(11110101)
(11110100)
(11110011)
(11110010)
(11110001)
(11110000)
(01110000)
(01101110)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);