// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<line>.*)$").unwrap();
let string = "GDS/Cordicate Admin follow-up required
Local Computer Files - Archive the offboarding users business folder
RPOP Office 365 (remove active licensing and add ons)
Zee Drive licensing deletion
Azure Active Directory deletion (Kardin)
MRI Account deletion
Avid XChange Account deletion
Distribution group lists removal - Everyone and RPOP
Global Address listing removal
Business phone extension license removal
Engineering Share deletion (if used)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}