using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"call is (?<callTime>\d+)";
string input = @"Total time taken for call is 1554
Total time taken for call is 2349685
Total time taken for call is 189";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}