# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*|\(([^()\r\n]+|(?>))\)//gm;t' <<< "(C,D) (E,F) (G,H) (J,K)
(C,D) (E,F) (G,H) (J,K)
((C,D) (E,F) (G,H) (J,K)"