using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+(?:[()-]\s*)?|[,()]\s*";
string substitution = @"\n";
string input = @"i-phone is popular - many people like it (user-friendly system, fast, good support)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}