package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+(?:[()-]\s*)?|[,()]\s*`)
var str = `i-phone is popular - many people like it (user-friendly system, fast, good support)`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}