# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[A-Za-z].*\R\K(?:[1-9]\R)+(?=0$)/\n/gm;t' <<< "ABC
5
0
gdfgdfg
-----------
GHN
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------"