using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!zz)\w+?zz\w+\b(?<!zz)";
string input = @"lorem ipsum buzz mezzo mix zztop but this is all azzazza azzzzza";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}