const regex = /\b(?!zz)\w+?zz\w+\b(?<!zz)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!zz)\\w+?zz\\w+\\b(?<!zz)', 'gm')
const str = `lorem ipsum buzz mezzo mix zztop but this is all azzazza azzzzza`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}