$re = '/.*\/0([^.]|$|\.(0{4,}.*|0{1,4}([^0-9]|$))).*/';
$str = '1/0
1/0.00+1
1/0.00001+1
1/0.0001+1
1/0.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);