#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(www\.)?(?:twitter\.com|x\.com)\/@?(\w{1,15})$"
Local $sString = "http://twitter.com/someuser" & @CRLF & _
"https://twitter.com/someuser" & @CRLF & _
"https://twitter.com/some_user" & @CRLF & _
"https://x.com/someuser" & @CRLF & _
"http://x.com/someuser" & @CRLF & _
"" & @CRLF & _
"twitter.com/someuser" & @CRLF & _
"x.com/someuser" & @CRLF & _
"" & @CRLF & _
"twitter.com/23123" & @CRLF & _
"x.com/this_string_is_bigger_then_15_letters" & @CRLF & _
"x.com/213?some=parameter"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")