// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)}\n(\s*){").unwrap();
let string = " [
{
\"ID\" : 230110850,
\"geometry\" : {
\"type\" : \"Point\",
\"s1\" : [ 22.226, 60.4 ]
},
\"properties\" : {
\"timestamp\" : 54,
}
{
\"ID\" : 265527480,
\"type\" : \"Feature\",
\"geometry\" : {
\"type\" : \"Point\",
\"s1\" : [ 22.2, 60.432 ]
},
\"properties\" : {
\"timestamp\" : 54,
}
]";
let substitution = "}\\n\\1},\\n\\1{";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}