using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|(\/\/.*)";
string input = @"<?
/* This is a comment */
cout << ""Hello World""; // prints Hello World
/*
* C++ comments can also
*/
cout << ""Hello World"";
/* Comment out printing of Hello World:
cout << ""Hello World""; // prints Hello World
*/
echo ""//This line was not a Comment, but ... "";
echo ""http://stackoverflow.com"";
echo 'http://stackoverflow.com/you can not match this line';
array = ['//', 'no, you can not match this line!!']
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}