using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+?(AAA\s+\S+)";
string input = @"NAME: ""test1"", DESCR: ""AAA 1111S ABC 48 BB (4 BBBB) TEST1 """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}