// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+?(AAA\s+\S+)").unwrap();
let string = "NAME: \"test1\", DESCR: \"AAA 1111S ABC 48 BB (4 BBBB) TEST1 \"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}