#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<IP>(?:[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])(?:\.(?:0|[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])){3}):(?P<PORT>(?:[1-9]|[1-9][0-9]{1,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))$"
Local $sString = "123.123.123.123:12345" & @CRLF & _
"123.0.123.2:23" & @CRLF & _
"123.01.123.2:23" & @CRLF & _
"123.10.123.2:23" & @CRLF & _
"0.1.2.3:1" & @CRLF & _
"1.0.2.3:1" & @CRLF & _
"223.255.255.255:123" & @CRLF & _
"225.255.255.255:123" & @CRLF & _
"12.231.21.232:65535"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")