#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)({LOOP})(.*?)({ENDLOOP})"
Local $sString = "{LOOP}" & @CRLF & _
" <option value="%SEL-VL%">%SEL-TXT%</option>" & @CRLF & _
"{ENDLOOP}" & @CRLF & _
"" & @CRLF & _
"{LOOP}" & @CRLF & _
" <span>Name %s</span>" & @CRLF & _
"{ENDLOOP}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")