using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)({LOOP}.*?{ENDLOOP})(.*)";
string substitution = @"$1{LOOP INTERNO}$3";
string input = @"{LOOP}
<span>Name %s</span>
{LOOP}
<option value=""%SEL-VL%"">%SEL-TXT%</option>
{ENDLOOP}
{ENDLOOP}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}