#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})"
Local $sString = "{imdb-tt0114746}" & @CRLF & _
"{tmdb-60948}" & @CRLF & _
"{tvdb-82}" & @CRLF & _
"[imdbid-tt0083658]" & @CRLF & _
"[tvdbid-356155]"
Local $sSubst = "$1db $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)