import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\[|\\{)(im|tm|tv)db(?:id)?-(?:tt)?(\\d+)(?:\\]|\\})";
final String string = "{imdb-tt0114746}\n"
+ "{tmdb-60948}\n"
+ "{tvdb-82}\n"
+ "[imdbid-tt0083658]\n"
+ "[tvdbid-356155]";
final String subst = "$1db $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}