re = /(?:\[|\{)(im|tm|tv)db(?:id)?-(?:tt)?(\d+)(?:\]|\})/m
str = '{imdb-tt0114746}
{tmdb-60948}
{tvdb-82}
[imdbid-tt0083658]
[tvdbid-356155]'
subst = '$1db $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result