using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\=\""([a-zA-Z0-9 ,.\/&%?=]+)\""";
string input = @"<match id=""18"" srs=""ICC Womens World Cup Qualifier, 2010"" mchDesc=""BANW vs PMGW"" mnum=""4th Match"">
<match id=""18"" type=""ODI"" srs=""ICC Womens World Cup Qualifier, 2017"" mchDesc=""BANW vs PMGW"" mnum=""4th Match, Group B"" vcity=""Colombo"" vcountry=""Sri Lanka"" grnd=""Colombo Cricket Club Ground"" inngCnt=""0"" datapath=""google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}