import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\=\\\"([a-zA-Z0-9 ,.\\/&%?=]+)\\\"";
final String string = "<match id=\"18\" srs=\"ICC Womens World Cup Qualifier, 2010\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match\">\n"
+ "<match id=\"18\" type=\"ODI\" srs=\"ICC Womens World Cup Qualifier, 2017\" mchDesc=\"BANW vs PMGW\" mnum=\"4th Match, Group B\" vcity=\"Colombo\" vcountry=\"Sri Lanka\" grnd=\"Colombo Cricket Club Ground\" inngCnt=\"0\" datapath=\"google.com/j2me/1.0/match/2017/index.php?=potato&?watermelon=true\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}