package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)1\.1\.1\.[12]\d{2}`)
var str = `Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?
тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}