import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1\\.1\\.1\\.[12]\\d{2}";
final String string = "Как в куче IP адресов с помощью регулярных выражений найти IP адреса вида 1.1.1.X, у которых X это 100-200?\n"
+ "тоесть 1.1.1.100, 1.1.1.101, 1.1.1.102 итд\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}