package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\d{13})_(?<fldrComponentPrimaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<fldrComponentSecondaryId>(\d{1,2}|x)p)(?:_r(?<fldrRevisionNumber>\d+))? Folder\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$`)
var str = `Obam_9781524763138_all_0p_r3 Folder/Links/apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/Obam_9781524763138_all_0p_r3.pdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}