const regex = /^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\d{13})_(?<fldrComponentPrimaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<fldrComponentSecondaryId>(\d{1,2}|x)p)(?:_r(?<fldrRevisionNumber>\d+))? Folder\/Links\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\d+))?\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<fldrMnemonic>.{2,8}?)_(?<fldrIsbn>\\d{13})_(?<fldrComponentPrimaryId>all|tx\\d{0,3}|lay\\d{0,3}|c0\\d{1,3}|c[^0]\\d{1,2}?)_(?<fldrComponentSecondaryId>(\\d{1,2}|x)p)(?:_r(?<fldrRevisionNumber>\\d+))? Folder\\\/Links\\\/(?<artFileName>.+?)(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>jpg|jpeg|psd|psb|tif|tiff|ai|eps|pdf|sct|bmp|ps)$', 'gm')
const str = `Obam_9781524763138_all_0p_r3 Folder/Links/apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple_r1.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/001_apple.pdf
Obam_9781524763138_all_0p_r3 Folder/Links/Obam_9781524763138_all_0p_r3.pdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}