$re = '/^([[:digit:]]{4})\-([[:digit:]]{2})\-([[:digit:]]{2}T[[:digit:]]{2})\:([[:digit:]]{2})\:([[:digit:]]{2})UTC$/m';
$str = '2021-05-09T14:23:38UTC';
$subst = "$1$2$3$4$5T";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;