package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+,\s*f\s*\.\s*\d\s*\d\s*-\s*\d\s*\d\s*-\s*\d\s*\d\s*\d\s*\d`)
var str = `Smith, John,
f. 25-12-1990
or only first part of below:
Smith, John, f. 25-12-
1990
Smith, John, f. 25-
12-1990`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}