using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\([^\\_\s]+)_([^\\_\s]+)_([^\\_\s]+)_";
string input = @"C:/Users/10MedicineA\20072018_medicineName_00222_01111
C:/Users/MedicineB\21072018_medicineName_03333_01121
Users/3A Medicine\\200726_21-PQmed_00223_07_01110";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}